Why can’t I install illumin8 on a Mac OS X version lower than 10.12?

The history of the Apple ecosystem is one of platform stability that is unique amongst computing platforms. A primary reason is the lack of platform fragmentation [lots of versions] that other platforms suffer from.

As a software developer on the Mac OS X platform, we are forced to update our developer environment by Apple to the latest operating system version. As the first released version of illumin8 was built using the latest dev environment, it is impacted by changes that Apple has made to their OS that render it incompatible with older versions of Mac OS X 10.12.

Going forward, we will make past releases available and the user will have the choice to maintain a configuration that it runs on. We will release patches when possible. The primary factor will be the compliance and compatibility requirements that are established by Apple.

 

Comment on this FAQ